Jump to content

Milimari

Members
  • Content Count

    10
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Milimari

  • Rank
    Membru

Profile Fields

  • City
    constanta
  1. am incercat si schema propusa in datasheet si tot degeaba. Ce pot sa ii mai fac la reset ca sa nu refac totul?
  2. multumesc toturor pentru solutii....concluzia finala este ca trebuie sa realizez alt cablaj datorita faptului ca firele care duc la prize trec pe langa microcontroler mai exact pe langa butonul de reset cum a spus sinus_pure si nu am alta posibilitate pentru ca totul este pe pozitie si nu pot sa mai modific nimic. Am realizat un test si cu optocuploare si rezultatul este acelasi iar dupa aceea am scos firele de la butonul de reset ai am indepartat placa cu uC de firele de la priza si montajul functioneaza perfect. CONCLUZIE: Cablurile de 230V nu trebuie sa treaca prin zona uC. O sa mai incerc varianta luata din datasheet ul PIC16F877A.
  3. donpetru am realizat si filtrul propus de tine si tot degeaba, nu stiu ce sa mai fac cu asta.
  4. Daca nu am consumatori pe prize tot montajul functioneaza corespunzator se aud releele cum cupleaza, uC nu se reseteaza.
  5. m-am gandit si la treaba cu optocuploarele dar pentru asta trebuie sa fac alt cablaj, sa cumpar piese, spatiul este cam insuficient...
  6. Multumesc pentru raspuns dar am incercat si asa
  7. Cine ma poate ajuta si pe mine cu o problema destul de delicata? Se da schema simplificata a unui controler pentru acvariu. Totul functioneaza conform comenzilor, mai exact atunci cand in priza 1 si priza2 nu am niciun consumator, releele cupleaza-decupleaza cum trebuie. Daca dau comanda pe priza 1 sau priza 2 sa inchida circuitul, adica sa activeze releul, consumatorul este alimentat (totul fara probleme). Atunci cand dau comanda sa deschida circuitul, in momentul cand decupleaza releul controlerul se reseteaza. Acelasi lucru se intampla atunci cand consumatorul este pur si simplu scos din priza. Dupa cum se vede si in schema partea de 230v este total separata. Mentionez ca releele sunt la 5v DC cu contacte 230VCA/10A. Incercari esuate: -Cu toate ca ULM 2003 are incorporata dioda de pe bobina releului pentru curent invers am pus si eu inca una in paralel si rezulatul este acelasi; -Aliimentare partea de forta si partea de comanda separat; -tot montajul alimentat de la aceeasi sursa; -dioda inseriata cu bobinele releelor; -condensatoare de 2200uF pe alimentare; -montajul a fost realizat prima data cu tranzistoare pe partea de forta(acelasi rezultat); multumesc anticipat si astept parerile dumneavoastra
  8. Sal. Studiez doar de doua luni microcontrolere PIC si vrea sa spun ca sunt chiar fascinat. M-am hotarat sa fac un controler pentru acvariu cu PIC16F877A si display 2x16, mai exact un ceas, un termometru, cateva alarme si cateva butoane pt a maviga prin meniu. Proiectul a fost facut pe bucati: - ceasul cu intrerupere TMR0 cu clock intern la 19660800 Hz; - ADC cu LM35 pt citire temperatura; - meniu....etc Toate functioneaza perfect....dar SEPARAT, nu reusesc sa le pun pe toate intr-un singur proiect, daca merge ceasul, nu merge sa intru in meniu si invers. Intrebarea este: Cum pot sa fac ca ceasul sa fie independent cumva de restul proiectului, sa ruleze in background cand vreau sa intru in meniu?...cand am iesit din meniu vrea ca ceasul sa ramana din nou pe ecran. Mentionez ca lucrarea este facuta in flowcode, cu toate ca nu cred ca are importanta. Oare sa trebuiasca ceva setat semnalul de ceas sau la intrerupere? Nu vreau sa folosesc real time clock (DS1307) sau altceva de genul asta. ms anticipat
×
×
  • Create New...

Important Information

We use cookies and related technologies to improve your experience on this website to give you personalized content and ads, and to analyze the traffic and audience of your website. Before continuing to browse www.tehnium-azi.ro, please agree to: Terms of Use.