Jump to content
Sign in to follow this  
Milimari

microcontroler cu releu

Recommended Posts

Eu as fi vrut sa vad traseele cablajului, nu schema.

Share this post


Link to post
Share on other sites

...decupleaza cu 100nF la masa cat mai aproape de pinii de alimentare la pic,ULN si ala de pe I²C (U3),eventual un filtru EMI pe alimentare trafo retzea,sau pune osciloscopul pe alimentari si magistrala si vezi unde ai ..,,antena'' ...care itzi da reset.Posibil sa ai ceva si de la cablaj...vreo mica antena de RF....

Share this post


Link to post
Share on other sites

folosesc un atmega8, care comanda 4 relee printr-un ULN2003 ca si in cazul tau. Pana acum nu am trecut la teste in instalatie, dar ma gandeam la separarea alimentarilor uC-ului. fata de partea de relee si chiar si a LCD-ului, astfel incat sa pot pune o baterie de back-up care sa imi tina "ceasul", cand pica reteaua.

As folosi o sursa gen L4949 pt alimentarea uC-ului care e ceva mai performanta decat un L7805.

 

Desi nu acesta este subiectul topicului am o intrebare: rezista contactele releului la sarcina respectiva sau mai folosesti un modul pentru forta? Personal as fi folosit mufe pentru toate elementele legate de placa, e mai usor la montat sau depanat.

Share this post


Link to post
Share on other sites

SPER SA AJUTE CU CEVA

Vorba dl.miron, acum ar fi util sa vedem si o imagine cu cablajul. Spre exemplu, ati decuplat cu un capacitor de 0.1uF alimentarea PIC-ului. Am vazut ca ati folosit doua capacitoare C3 pe iesirea stabilizatoarelor de tensiune dar in realitate acestea sunt amplasate cat mai aproape de MCU ? Si ar mai fi cateva observatii dar sa vad intai cablajul.

Share this post


Link to post
Share on other sites

Nu vad decat doua cauze posibile.

Prima ar fi inductante parazite mari si/sau aflate in apropierea conductoarelor contactelor. In care caz decuplarea cu 100n inclusiv a traseelor de semnal (viteza e mica) este benefica. Trebuiesc departate fizic conductoarele contactelor de tot sistemul. Trebuiesc scurtate la maxim posibil toate conductoarele. Decuplari cu 100n peste tot unde nu este viteza si se poate. Un cablaj bun cu evitare bucle de masa (poate il postezi). Astfel de fenomene apar si unde se fac cablaje improvizate cu multe conductoare lungi.

A doua este data de eventuali paraziti care vin pe retea chiar de la consumatorii de pe contacte. Aici ar trebui decuplate contactele cu 47-100 ohmi+100-220n, filtre retea, conduri 100n paralel pe diode redresoare, etc.

Share this post


Link to post
Share on other sites

multumesc toturor pentru solutii....concluzia finala este ca trebuie sa realizez alt cablaj datorita faptului ca firele care duc la prize trec pe langa microcontroler mai exact pe langa butonul de reset cum a spus sinus_pure si nu am alta posibilitate pentru ca totul este pe pozitie si nu pot sa mai modific nimic. Am realizat un test si cu optocuploare si rezultatul este acelasi iar dupa aceea am scos firele de la butonul de reset ai am indepartat placa cu uC de firele de la priza si montajul functioneaza perfect.

CONCLUZIE: Cablurile de 230V nu trebuie sa treaca prin zona uC.

O sa mai incerc varianta luata din datasheet ul PIC16F877A.

post-18149-0-15962100-1391353959_thumb.jpg

Edited by Milimari

Share this post


Link to post
Share on other sites

 

CONCLUZIE: Cablurile de 230V nu trebuie sa treaca prin zona uC.

 

Este si motivul pentru care a vrut sa vad cablajul(traseele).

  • Like 1

Share this post


Link to post
Share on other sites

am incercat si schema propusa in datasheet si tot degeaba. Ce pot sa ii mai fac la reset ca sa nu refac totul?

Share this post


Link to post
Share on other sites

Decupleaza cu capacitati tot ce poti. Daca nu tine cu 100n, incearca cu valori mai mari. Sau tantal electrolitici. Inclusiv butonul de reset. Toate comenzile si iesirile/intrarile uC care nu presupun viteza sau frecvente mari. Asta e cam tot ce poti sa faci pastrand situatia. Umple-l de decuplari la masa.

  • Like 1

Share this post


Link to post
Share on other sites

eu am la activ mai multe proiecte de genul asta, eu am lasat cel putin 2-3 cm intre partea de forta si microcotroler, e foarte sensibil la perturbatii electromagnetice, recomand niste rezistente intre ULN2003 si microcontroler de vreo 1k.

Edited by Vlad Mihai
  • Like 1

Share this post


Link to post
Share on other sites

chestia cu cablajul e...teoretica doar,nu potzi sa vezi cu ochiul liber ceea ce vede un osciloscop si daca o luam pe partea cealalalta poate atzi vazut ca in domeniul asta unde se folosesc procesoare si magistrale de comunicatzie trebuie decuplari la greu .Uneori e imposibil de evitat un traseu de cablaj si de aceea trebuie gasite alte solutzii pt o functzionare normala.Daca va uitatzi la o placa de sunet sau una video o sa vedetzi cate decuplari are si cat de scurte sunt traseele de cablaj...sa nu mai zic la o placa de baza de PC.Totusi ma bucur ca @Milimari a gasit singur cauza resetului... :yes:

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use cookies and related technologies to improve your experience on this website to give you personalized content and ads, and to analyze the traffic and audience of your website. Before continuing to browse www.tehnium-azi.ro, please agree to: Terms of Use.