Jump to content
Sign in to follow this  
Milimari

microcontroler cu releu

Recommended Posts

Cine ma poate ajuta si pe mine cu o problema destul de delicata?

Se da schema simplificata a unui controler pentru acvariu. Totul functioneaza conform comenzilor, mai exact atunci cand in priza 1 si priza2 nu am niciun consumator, releele cupleaza-decupleaza cum trebuie. Daca dau comanda pe priza 1 sau priza 2 sa inchida circuitul, adica sa activeze releul, consumatorul este alimentat (totul fara probleme). Atunci cand dau comanda sa deschida circuitul, in momentul cand decupleaza releul controlerul se reseteaza. Acelasi lucru se intampla atunci cand consumatorul este pur si simplu scos din priza. Dupa cum se vede si in schema partea de 230v este total separata. Mentionez ca releele sunt la 5v DC cu contacte 230VCA/10A.

Incercari esuate:

-Cu toate ca ULM 2003 are incorporata dioda de pe bobina releului pentru curent invers am pus si eu inca una in paralel si rezulatul este acelasi;

-Aliimentare partea de forta si partea de comanda separat;

-tot montajul alimentat de la aceeasi sursa;

-dioda inseriata cu bobinele releelor;

-condensatoare de 2200uF pe alimentare;

-montajul a fost realizat prima data cu tranzistoare pe partea de forta(acelasi rezultat);

multumesc anticipat si astept parerile dumneavoastra

post-18149-0-89306200-1391275890_thumb.jpg

Edited by Milimari

Share this post


Link to post
Share on other sites

Incercati post-9-0-03604400-1391276310_thumb.jpg asa.

Diodele pot fi 1N4148 sau 1N4001 ...7.

Edited by miron1947

Share this post


Link to post
Share on other sites

Incercati post-9-0-03604400-1391276310_thumb.jpg asa.

Diodele pot fi 1N4148 sau 1N4001 ...7.

 

Multumesc pentru raspuns dar am incercat si asa

Share this post


Link to post
Share on other sites

incearca si cu un optocuplor gen MOC3042 cu zero-crossing

 

MOC3021%20Resistive%20Load.jpg

Share this post


Link to post
Share on other sites

m-am gandit si la treaba cu optocuploarele dar pentru asta trebuie sa fac alt cablaj, sa cumpar piese, spatiul este cam insuficient...

Share this post


Link to post
Share on other sites

Resetarea apare numai datorita bobinelor (contacte in gol) sau numai cu consumator pe contacte?

Ai incercat fara consumatori pe contacte?

Edited by smilex

Share this post


Link to post
Share on other sites

Daca nu am consumatori pe prize tot montajul functioneaza corespunzator se aud releele cum cupleaza, uC nu se reseteaza.

Share this post


Link to post
Share on other sites

Incercati cu condensatori de cca. 10nF/400V pe contactele releelor.

Share this post


Link to post
Share on other sites

Aveti cumva montat un filtru pe partea de alimentare (230V) a montajului prezentat mai sus. Incercati sa construiti un filtru de acest tip in serie cu primarul transformatorului:

filtru 230VAC cu diode.jpg

unde puteti folosi diode 1N4007 iar capacitatea condensatoarelor poate fi si de 2200uF - 6.3V.

 

Numai bine

Share this post


Link to post
Share on other sites

donpetru am realizat si filtrul propus de tine si tot degeaba, nu stiu ce sa mai fac cu asta.

Share this post


Link to post
Share on other sites

Am si eu in lucru o automatizare pentru centrala termica care trebuie sa asigure comutarea vanei pe 3 cai pt incalzire boiler sau incalzire pardoseala/calorifere, asigurarea unor delay-uri la comutarea vanei, mod de lucru noapte/zi pentru incalzirea apei din boiler, etc.

folosesc un atmega8, care comanda 4 relee printr-un ULN2003 ca si in cazul tau. Pana acum nu am trecut la teste in instalatie, dar ma gandeam la separarea alimentarilor uC-ului. fata de partea de relee si chiar si a LCD-ului, astfel incat sa pot pune o baterie de back-up care sa imi tina "ceasul", cand pica reteaua.

As folosi o sursa gen L4949 pt alimentarea uC-ului care e ceva mai performanta decat un L7805.

 

http://imageshack.co...47/379/cn3f.jpg

Edited by baldovica

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We use cookies and related technologies to improve your experience on this website to give you personalized content and ads, and to analyze the traffic and audience of your website. Before continuing to browse www.tehnium-azi.ro, please agree to: Terms of Use.