Sari la conținut

Postări Recomandate

a durat un pic pentru ca nu folosisem MPLAB (sau picuri) in viata mea, si pana am facut download si m-am prins cum sta treaba...

eu sunt mai mult cu Atmel (AVR) la astea mici pe 8 biti.

Bafta in continuare

RR

Link spre post
Distribuie pe alte site-uri
  • Răspunsuri 49
  • Created
  • Ultimul Răspuns

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Nici mie nu imi iese :shock3:

: Cannot open file (Include File "FP.TXT"

asta ce mai e de unde il iau??

 

 

 

----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\Administrator\Desktop\New Folder\lcmeter.mcp' started.
Language tool versions: MPASMWIN.exe v5.37, mplink.exe v4.37, mplib.exe v4.37
Preprocessor symbol `__DEBUG' is defined.
Sat Jan 15 23:31:25 2011
----------------------------------------------------------------------
Make: The target "C:\Documents and Settings\Administrator\Desktop\New Folder\lc.o" is out of date.
Executing: "C:\Program Files\Microchip\MPASM Suite\MPASMWIN.exe" /q /p16F628 "lc.asm" /l"lc.lst" /e"lc.err" /o"lc.o" /d__DEBUG=1
Message[301] C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 159 : MESSAGE: (Processor = 16F628)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 362 : Symbol not previously defined (Calibr)
Warning[202] C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 362 : Argument out of range.  Least significant bits used.
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 526 : Symbol not previously defined (Cintro)
Warning[202] C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 526 : Argument out of range.  Least significant bits used.
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 540 : Symbol not previously defined (Lintro)
Warning[202] C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 540 : Argument out of range.  Least significant bits used.
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1057 : Symbol not previously defined (Unit4)
Warning[202] C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1057 : Argument out of range.  Least significant bits used.
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1101 : Symbol not previously defined (FPS24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1104 : Symbol not previously defined (FPD24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1107 : Symbol not previously defined (FPM24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1191 : Symbol not previously defined (INT2424)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1275 : Symbol not previously defined (FLO2424)
Error[105]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1348 : Cannot open file (Include File "FP.TXT" not found)
Halting build on first failure as requested.
----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\Administrator\Desktop\New Folder\lcmeter.mcp' failed.
Language tool versions: MPASMWIN.exe v5.37, mplink.exe v4.37, mplib.exe v4.37
Preprocessor symbol `__DEBUG' is defined.
Sat Jan 15 23:31:37 2011
----------------------------------------------------------------------
BUILD FAILED

post-2611-007983600 1295127614_thumb.jpg

Link spre post
Distribuie pe alte site-uri

Ok...treaba sta in felul urmator: hex-ul rezultat la RR este functional la fel ca si cel al autorului (partea de voltmetru lipseste din meniu si cea de tahometru se blocheaza ).Treaba este ca am vazut pe youtube dispozitivul functionand la mai multe persoane . Cred ca buba este la programare...o treaba care nu mi s-a mai intamplat niciodata si pt mine este foarte curioasa .

Iata cum arata hexul cand il incarc

 

post-8739-075884000 1295159449_thumb.jpg

 

si cum arata in pic la citirea dupa ce l-am programat

 

post-8739-009129600 1295159501_thumb.jpg

 

Voi ce parere aveti despre asta ?

Link spre post
Distribuie pe alte site-uri

cata2,

 

1.sursele alea ASM arata aiurea, faptul ca nu s-a compilat din prima si a trebuit sa editez fisierul asm, nu e un semn bun. (da-mi si mie link-ul la pagina aia sa arunc un ochi pe acolo, poate ne scapa ceva)

2. daca PIC-ul e protejat la citire atunci cand citesti inapoi apare totul zero.

RR

 

Trax,

 

ai selectat PIC-ul traget gresit.

pe prima linie in asm scrie pentru ce pic este.

RR

Editat de roadrunner
Link spre post
Distribuie pe alte site-uri

cred ca ne scapa o optine de compilare sau ceva, e suspect ca un proiect asa stabil (dupa ce am citi pagina de la lik-ul dat de tine) poate sa sa aiba atatea warning-uri la compilare. Sigur mai e vro' optiune in asamblor care trebuie s-o setez, daca nu-i dau de cap le trimit un mail la baietii astia. Chiar tu ce variant de hardware ai? (ca sunt mai multe pe pagina aia)

RR

 

Cata,

daca ai timp (si nervi) incearca hex-ul atasat , nu-mi pun mari sperante in el dara am schimabat niste optiuni la build (si am gasit si optiunea ca sa nu trebuiasaca sa schimbi "start" in "START" - se paote dezactiva case sensitive in parser)

test.zip

Editat de roadrunner
Link spre post
Distribuie pe alte site-uri

Pei e pic16f628 e pentru acel lc metru care lam facut si la sfarsit are textele de afisare si am vrut sa le schimb

 

;********************************************************************    

   INCLUDE <FP.TXT>

;********************************************************************
;
;    Text Strings (stored in data EEPROM)
;

       ORG 0x2100

ovr    de    " Capacitate Mare ",0
Unit1    de    " nF",0
Unit2    de    " pF",0
Unit3    de    " Calibrare TRAX ",0

cal_p    de    0x27,0x10        ; Initial value = 10000

    END

;********************************************************************

 

 

Nu ma lasa sa fac modificarea???Trebuie sa am acelasi spatiu de caractere ca cel original sau mai trebuie schimbat ceva :shock3:

 

 

;********************************************************************    

   INCLUDE <FP.TXT>

;********************************************************************
;
;    Text Strings (stored in data EEPROM)
;

       ORG 0x2100

ovr    de    "   Over Range   ",0
Unit1    de    " nF",0
Unit2    de    " pF",0
Unit3    de    " mH",0
Unit4    de    " uH",0
Cintro    de    " C = ",0
Lintro    de    " L = ",0
Calibr  de    "   Calibrating  ",0

cal_p    de    0x27,0x10        ; Initial value = 10000

    END

 

Hopaa stai ca acum am observat ca imi lipseste din text :morning: O luam de la capat

Fac modificarea...

;********************************************************************    

   INCLUDE <FP.TXT>

;********************************************************************
;
;    Text Strings (stored in data EEPROM)
;

       ORG 0x2100

ovr    de    " Capacitate mare",0
Unit1    de    " nF",0
Unit2    de    " pF",0
Unit3    de    " mH",0
Unit4    de    " uH",0
Cintro    de    " C = ",0
Lintro    de    " L = ",0
Calibr  de    " Calibr.TRAX L/C",0

cal_p    de    0x27,0x10        ; Initial value = 10000

    END

;********************************************************************

 

Bun, la cele 2 texte am cu acel spatiu in total 16 caractere, cred ca e bine deoarece lcd are tot 16 pe 1 rand

Si MPLAB imi da aceeasi chestie...cred ca nu ma lasa sa fac modificarea...

----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\Administrator\Desktop\New Folder\lcmeter.mcp' started.
Language tool versions: MPASMWIN.exe v5.37, mplink.exe v4.37, mplib.exe v4.37
Preprocessor symbol `__DEBUG' is defined.
Sun Jan 16 11:30:08 2011
----------------------------------------------------------------------
Clean: Deleting intermediary and output files.
Clean: Deleted file "C:\Documents and Settings\Administrator\Desktop\New Folder\lcmeter.mcs".
Clean: Done.
Executing: "C:\Program Files\Microchip\MPASM Suite\MPASMWIN.exe" /q /p16F628 "lc.asm" /l"lc.lst" /e"lc.err" /o"lc.o" /d__DEBUG=1
Message[301] C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 159 : MESSAGE: (Processor = 16F628)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1101 : Symbol not previously defined (FPS24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1104 : Symbol not previously defined (FPD24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1107 : Symbol not previously defined (FPM24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1191 : Symbol not previously defined (INT2424)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1275 : Symbol not previously defined (FLO2424)
Error[105]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1348 : Cannot open file (Include File "FP.TXT" not found)
Halting build on first failure as requested.
----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\Administrator\Desktop\New Folder\lcmeter.mcp' failed.
Language tool versions: MPASMWIN.exe v5.37, mplink.exe v4.37, mplib.exe v4.37
Preprocessor symbol `__DEBUG' is defined.
Sun Jan 16 11:30:09 2011
----------------------------------------------------------------------
BUILD FAILED

 

Am sa incerc sa vad daca merge cu fisierul asm fara modificarea aceea de scris.

 

La fel imi da...deci asm de la ei are ceva? :toiletghost:

----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\Administrator\Desktop\New Folder\lcmeter.mcp' started.
Language tool versions: MPASMWIN.exe v5.37, mplink.exe v4.37, mplib.exe v4.37
Preprocessor symbol `__DEBUG' is defined.
Sun Jan 16 11:39:04 2011
----------------------------------------------------------------------
Clean: Deleting intermediary and output files.
Clean: Done.
Executing: "C:\Program Files\Microchip\MPASM Suite\MPASMWIN.exe" /q /p16F628 "lc.asm" /l"lc.lst" /e"lc.err" /o"lc.o" /d__DEBUG=1
Message[301] C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 159 : MESSAGE: (Processor = 16F628)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1101 : Symbol not previously defined (FPS24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1104 : Symbol not previously defined (FPD24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1107 : Symbol not previously defined (FPM24)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1191 : Symbol not previously defined (INT2424)
Error[113]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1275 : Symbol not previously defined (FLO2424)
Error[105]   C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1348 : Cannot open file (Include File "FP.TXT" not found)
Halting build on first failure as requested.
----------------------------------------------------------------------
Debug build of project `C:\Documents and Settings\Administrator\Desktop\New Folder\lcmeter.mcp' failed.
Language tool versions: MPASMWIN.exe v5.37, mplink.exe v4.37, mplib.exe v4.37
Preprocessor symbol `__DEBUG' is defined.
Sun Jan 16 11:39:05 2011
----------------------------------------------------------------------
BUILD FAILED

 

Aici este siteul cu asm-ul http://sites.google.com/site/vk3bhr/home/index2-html

Sa fie de la acel fisier header?? :biggrin: ca eu asa stiu ca trebuie sa pun...adica stiu de la cineva care am avut parte doar de 1 zi sa imi dea programale necesare da programare tot nu am invatat...mia aratat cum sa ma uit prin pic ce stie el sa faca....ca sa stiu ce fac...dar nu am mai avut timp mai departe...eram la un simpozion iar dl. era din iasi...asta e

post-2611-070890100 1295171174_thumb.jpg

Link spre post
Distribuie pe alte site-uri

Trax baiete, nu deschizi tu alt thread pentru asta ca e varza, nu mai stiu despre ce vorbesc si cu cine.

nu putem vorbii de doua proiecte in acelasi timp.

 

Error[105] C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\NEW FOLDER\LC.ASM 1348 : Cannot open file (Include File "FP.TXT" not found)
asta e buba la tine, nu gaseste fiserul FP.txt ca sa-l includa.

RR

Editat de roadrunner
Link spre post
Distribuie pe alte site-uri

Am versiunea 4.35 cea realizata cu pic 16f88 pe modelul de cablaj a lui Serghei Zhuravlev . Serghei are si un clip pe youtube cu el functional 100%. Curios este ca Philip Sun este recunoscut in bransa noastra de modelisti ca un om serios si mai ales ca mai am proiecte realizate dupa scheme de ale lui si merg foarte bine .

Link spre post
Distribuie pe alte site-uri

Hmm...am citit si eu asm-ul si desi nu ma pricep am gasit ceva....tinand apasat 2 butoane la pornire intra in modul voltmetru care imi lipsea din meniul principal si functioneaza chiar corect. Ma duc sa iau o cazma sa mai sap un pic .A ramas taho...

Link spre post
Distribuie pe alte site-uri
  • 1 month later...

Sa traiasca roadrunner...... merge domnule foarte bine:

 

Cata2,

ma bucur ca te-am putut ajuta.

RR

 

PS - nu inteleg de ce trebuie sa va puneti nick-urile pe carcase, pe scheme, pe pereti...

RR

Link spre post
Distribuie pe alte site-uri

Creează un cont sau autentifică-te pentru a adăuga comentariu

Trebuie să fi un membru pentru a putea lăsa un comentariu.

Creează un cont

Înregistrează-te pentru un nou cont în comunitatea nostră. Este simplu!

Înregistrează un nou cont

Autentificare

Ai deja un cont? Autentifică-te aici.

Autentifică-te acum
  • Navigare recentă   0 membri

    Nici un utilizator înregistrat nu vede această pagină.




×
×
  • Creează nouă...

Informații Importante

Folosim cookie-uri și tehnologii asemănătoare pentru a-ți îmbunătăți experiența pe acest website, pentru a-ți oferi conținut și reclame personalizate și pentru a analiza traficul și audiența website-ului. Înainte de a continua navigarea pe www.tehnium-azi.ro te rugăm să fii de acord cu: Termeni de Utilizare.

ATENTIE !!! Functionarea Tehnium Azi depinde de afisarea de reclame.

Pentru a putea accesa in continuoare site-ul web www.tehnium-azi.ro, va rugam sa dezactivati extensia ad block din browser-ul web al vostru. Dupa ce ati dezactivat extensia ad block din browser dati clic pe butonul de mai jos.

Multumim.

Apasa acest buton dupa dezactivarea extensiei Adblock